toddr.org - Update in progress
Incident Report for Todd Rylaarsdam
Resolved
The update has been completed and the outage has been resolved.
Posted Mar 30, 2023 - 16:02 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 30, 2023 - 15:45 CDT
This incident affected: toddr.org.